PDA

View Full Version : Help. Help, Help! Debian server with Oscam and CCcam



graham1981
17-12-2011, 09:42 PM
Hello, thanks for taking the time to read my post. I am needing some help in getting a server runnning,

I currently have Debian 6 installed on a dedicated machine, and have used the auto-install script(Automated Oscam/CCcam 2.1.3 Install Package For Debian 6) to install the required files etc

I have installed an old card reader that I used to use in the cable scene a few years back, its a USB infinity, This has installed ok and is now in phoenix mode (3.68)

My problem is no matter how many times i have tried I can not get my card reader to share the card from Oscam, its a white uk card. I have now re-installed the system back to default settings and then ran the auto script again, so everything is at square one, I have already installed the usb infinity card reader.

I should point out that the card reader does see the card, but currently Oscam is saying status : NEED INIT (no entitlements)



I have included the config files below, they have not been touched other than adding my reader to oscam.server



Oscam.Server

# oscam.server generated automatically by Streamboard OSCAM 1.20-unstable_svn build #6059
# Read more: [Only registered and activated users can see links]

[reader]
label = ***UK
protocol = mouse
device = /dev/ttyUSB0
blockemm-u = 0
blockemm-s = 0
blockemm-g = 1
blockemm-unknown = 1
emmcache = 1,3,2
group = 1
caid = 0963





Oscam.Conf


[global]
nice =
WaitForCards =
preferlocalcards =
ClientTimeout =
CacheDelay =
saveinithistory =
[webif]
[Only registered and activated users can see links] = 8888
[Only registered and activated users can see links] = admin
[Only registered and activated users can see links] = admin
[Only registered and activated users can see links] = 127.0.0.1,192.168.0.0-192.168.255.255
# protocols
[newcamd]
key = 0102030405060708091011121314
port = 10002@1234:5



Oscam.user

[account]
user = test1
pwd = test2
group = 1




I currently have CCCam.Cfg in /Emu/CCcam/


SERVER LISTEN PORT : 12000
ALLOW TELNETINFO: yes
ALLOW WEBINFO: yes
WEBINFO USERNAME :root
WEBINFO PASSWORD :dreambox
TELNETINFO USERNAME :root
TELNETINFO PASSWORD :dreambox
TELNETINFO LISTEN PORT : 16000
WEBINFO LISTEN PORT : 16001
ZAP OSD TIME :0
OSD USERNAME :root
OSD PASSWORD :dreambox
OSD PORT :80
SHOW TIMING : yes
DEBUG : no
NEWCAMD CONF : yes
#DISABLE EMM : yes
#EXTRA EMM LEVEL : yes
SHOW EXTENEDED CLIENT INFO : yes
MINI OSD : no
#MINIMUM DOWNHOPS: 1
CHANNELINFO FILE : /var/etc/CCcam.channelinfo
PROVIDERINFO FILE : /var/etc/CCcam.providers
CAID PRIO FILE : /var/etc/CCcam.prio
LOG WARNINGS : /tmp/warnings.txt
SOFTKEY FILE : /var/keys/SoftCam.Key
AUTOROLL FILE : /var/keys/AutoRoll.Key
#STATIC CW FILE : /var/keys/constant.cw
#BOXKEY: /dev/sci0
#SMARTCARD CLOCK FREQUENCY: /dev/sci0 6800000

N: 127.0.0.1 10000 test1 test2 01 02 03 04 05 06 07 08 09 10 11 12 13 14 256



I really hope someone can help me get started, i feel so close, yet so far lol

master G
17-12-2011, 09:56 PM
Hello, thanks for taking the time to read my post. I am needing some help in getting a server runnning,

I currently have Debian 6 installed on a dedicated machine, and have used the auto-install script(Automated Oscam/CCcam 2.1.3 Install Package For Debian 6) to install the required files etc

I have installed an old card reader that I used to use in the cable scene a few years back, its a USB infinity, This has installed ok and is now in phoenix mode (3.68)

My problem is no matter how many times i have tried I can not get my card reader to share the card from Oscam, its a white uk card. I have now re-installed the system back to default settings and then ran the auto script again, so everything is at square one, I have already installed the usb infinity card reader.

I should point out that the card reader does see the card, but currently Oscam is saying status : NEED INIT (no entitlements)



I have included the config files below, they have not been touched other than adding my reader to oscam.server



Oscam.Server

# oscam.server generated automatically by Streamboard OSCAM 1.20-unstable_svn build #6059
# Read more: [Only registered and activated users can see links]

[reader]
label = ***UK
protocol = mouse
device = /dev/ttyUSB0
blockemm-u = 0
blockemm-s = 0
blockemm-g = 1
blockemm-unknown = 1
emmcache = 1,3,2
group = 1
caid = 0963





Oscam.Conf


[global]
nice =
WaitForCards =
preferlocalcards =
ClientTimeout =
CacheDelay =
saveinithistory =
[webif]
[Only registered and activated users can see links] = 8888
[Only registered and activated users can see links] = admin
[Only registered and activated users can see links] = admin
[Only registered and activated users can see links] = 127.0.0.1,192.168.0.0-192.168.255.255
# protocols
[newcamd]
key = 0102030405060708091011121314
port = 10002@1234:5



Oscam.user

[account]
user = test1
pwd = test2
group = 1




I currently have CCCam.Cfg in /Emu/CCcam/


SERVER LISTEN PORT : 12000
ALLOW TELNETINFO: yes
ALLOW WEBINFO: yes
WEBINFO USERNAME :root
WEBINFO PASSWORD :dreambox
TELNETINFO USERNAME :root
TELNETINFO PASSWORD :dreambox
TELNETINFO LISTEN PORT : 16000
WEBINFO LISTEN PORT : 16001
ZAP OSD TIME :0
OSD USERNAME :root
OSD PASSWORD :dreambox
OSD PORT :80
SHOW TIMING : yes
DEBUG : no
NEWCAMD CONF : yes
#DISABLE EMM : yes
#EXTRA EMM LEVEL : yes
SHOW EXTENEDED CLIENT INFO : yes
MINI OSD : no
#MINIMUM DOWNHOPS: 1
CHANNELINFO FILE : /var/etc/CCcam.channelinfo
PROVIDERINFO FILE : /var/etc/CCcam.providers
CAID PRIO FILE : /var/etc/CCcam.prio
LOG WARNINGS : /tmp/warnings.txt
SOFTKEY FILE : /var/keys/SoftCam.Key
AUTOROLL FILE : /var/keys/AutoRoll.Key
#STATIC CW FILE : /var/keys/constant.cw
#BOXKEY: /dev/sci0
#SMARTCARD CLOCK FREQUENCY: /dev/sci0 6800000

N: 127.0.0.1 10000 test1 test2 01 02 03 04 05 06 07 08 09 10 11 12 13 14 256



I really hope someone can help me get started, i feel so close, yet so far lol


The port you have set for the nline does not match what you have in your CCcam.cfg


# protocols
[newcamd]
key = 0102030405060708091011121314
port = 10002@1234:5


N: 127.0.0.1 10000 test1 test2 01 02 03 04 05 06 07 08 09 10 11 12 13 14 256



I presume port = 10002@1234:5 is actually 10002@0963:000000
If not you need to change this too.

graham1981
17-12-2011, 10:09 PM
Ok changed the port although if i goto my server and look at the web config for Oscam it still reads needs Init (no entitlements)


2011/12/17 21:05:56 0 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
2011/12/17 21:05:56 0 s signal handling initialized (type=sysv)
2011/12/17 21:05:56 0 s can't open file "/usr/local/etc/oscam.srvid" (err=2 No such file or directory), no service-id's loaded
2011/12/17 21:05:56 0 s 37 tier-id's loaded
2011/12/17 21:05:56 0 s 1000 provid's loaded
2011/12/17 21:05:56 0 s can't open file "/usr/local/etc/oscam.ird" (errno=2 No such file or directory) i***** guessing not loaded
2011/12/17 21:05:56 0 s Starting listener 0
2011/12/17 21:05:56 0 s monitor: disabled
2011/12/17 21:05:56 0 s Starting listener 0
2011/12/17 21:05:56 0 s camd35: disabled
2011/12/17 21:05:56 0 s Starting listener 0
2011/12/17 21:05:56 0 s cs378x: disabled
2011/12/17 21:05:56 0 s Starting listener 0
2011/12/17 21:05:56 0 s newcamd: initialized (fd=5, port=10000, ip=0.0.39.60, crypted)
2011/12/17 21:05:56 0 s -> CAID: 1234 PROVID: 000005
2011/12/17 21:05:56 0 s Starting listener 0
2011/12/17 21:05:56 0 s pandora: disabled
2011/12/17 21:05:56 0 s Starting listener 0
2011/12/17 21:05:56 0 s radegast: disabled
2011/12/17 21:05:56 0 s http thread started
2011/12/17 21:05:56 0 s reader check thread started
2011/12/17 21:05:56 0 s check thread started
2011/12/17 21:05:56 0 s creating thread for device /dev/ttyUSB0
2011/12/17 21:05:56 0 s loadbalancer: can't read from file /tmp/.oscam/stat
2011/12/17 21:05:56 0 s waiting for local card init
2011/12/17 21:05:56 A0640B0 h HTTP Server listening on port 8888
2011/12/17 21:05:59 A0628B8 r reader ***uk initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)
2011/12/17 21:05:59 0 ***uk card detected
2011/12/17 21:06:04 A0628B8 r ATR: 3F FD 13 25 02 50 00 0F 33 B0 0F 68 (left some of ATR off)

master G
17-12-2011, 10:22 PM
I missed this bit

currently have CCCam.Cfg in /Emu/CCcam/



It should be in /var/ect

musogeek
17-12-2011, 10:24 PM
When was the last time this white UK card was used?

graham1981
17-12-2011, 10:33 PM
I missed this bit


It should be in /var/ect



Ok thanks, I have now moved the config to the correct collection, but no change =(

graham1981
17-12-2011, 10:35 PM
New log from Oscam
2011/12/17 21:33:07 0 s client max. idle=120 sec, debug level=0
2011/12/17 21:33:07 0 s max. logsize=10 Kb, loghistorysize=4096 bytes
2011/12/17 21:33:07 0 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=0 ms
2011/12/17 21:33:07 0 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
2011/12/17 21:33:07 0 s signal handling initialized (type=sysv)
2011/12/17 21:33:07 0 s can't open file "/usr/local/etc/oscam.srvid" (err=2 No such file or directory), no service-id's loaded
2011/12/17 21:33:07 0 s 37 tier-id's loaded
2011/12/17 21:33:07 0 s 1000 provid's loaded
2011/12/17 21:33:07 0 s can't open file "/usr/local/etc/oscam.ird" (errno=2 No such file or directory) i***** guessing not loaded
2011/12/17 21:33:07 0 s Starting listener 0
2011/12/17 21:33:07 0 s monitor: disabled
2011/12/17 21:33:07 0 s Starting listener 0
2011/12/17 21:33:07 0 s camd35: disabled
2011/12/17 21:33:07 0 s Starting listener 0
2011/12/17 21:33:07 0 s cs378x: disabled
2011/12/17 21:33:07 0 s Starting listener 0
2011/12/17 21:33:07 0 s newcamd: initialized (fd=5, port=10000, ip=127.0.0.1, crypted)
2011/12/17 21:33:07 0 s -> CAID: 0693 PROVID: 000000
2011/12/17 21:33:07 0 s Starting listener 0
2011/12/17 21:33:07 0 s pandora: disabled
2011/12/17 21:33:07 0 s Starting listener 0
2011/12/17 21:33:07 0 s radegast: disabled
2011/12/17 21:33:07 0 s http thread started
2011/12/17 21:33:07 0 s reader check thread started
2011/12/17 21:33:07 0 s check thread started
2011/12/17 21:33:07 0 s creating thread for device /dev/ttyUSB0
2011/12/17 21:33:07 0 s loadbalancer: can't read from file /tmp/.oscam/stat
2011/12/17 21:33:07 0 s waiting for local card init
2011/12/17 21:33:07 9FF60B0 h HTTP Server listening on port 8888
2011/12/17 21:33:09 9FF48B8 r reader ***uk initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)
2011/12/17 21:33:10 0 ***uk card detected
2011/12/17 21:33:14 9FF48B8 r ATR: 3F FD 13 25 02 50 00 0E 33 B0 0F 69 FE 4A 50 D0 00 00 53 58 02
2011/12/17 21:33:16 9FF48B8 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.57 Mhz
2011/12/17 21:33:17 9FF48B8 r card system not supported
2011/12/17 21:33:17 9FF48B8 r Normal mode failed, reverting to Deprecated Mode
2011/12/17 21:33:20 9FF48B8 r ATR: 3F FD 13 25 02 50 00 0E 33 B0 0E 69 FE 4A 50 D0 00 00 53 58 02
2011/12/17 21:33:21 9FF48B8 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.57 Mhz
2011/12/17 21:33:22 9FF48B8 r card system not supported
2011/12/17 21:33:22 9FF48B8 r card initializing error
2011/12/17 21:33:23 0 s init for all local cards done
2011/12/17 21:33:23 0 s anti cascading disabled
2011/12/17 21:33:23 9FF8588 c client connected to 10000 port
2011/12/17 21:33:23 9FF8588 c anonymous disconnected from 127.0.0.1
2011/12/17 21:33:23 9FF8588 c thread B73ABB70 ended!
2011/12/17 21:33:26 9FF9D20 c client connected to 10000 port
2011/12/17 21:33:26 9FF9D20 c encrypted newcamd:10000-client 127.0.0.1 granted (test1, au=off)
2011/12/17 21:33:26 9FF9D20 c user test1 authenticated successfully (CCcam)
2011/12/17 21:33:26 9FF9D20 c AU disabled for user test1

graham1981
17-12-2011, 10:36 PM
This is from CCCam

Server connections: 1
+----------------------+------------+-------+--------+----------------+-------+-------------------------------+
| Host | Connected | Type | Version| NodeID | Cards | CAID/Idents |
+----------------------+------------+-------+--------+----------------+-------+-------------------------------+
|127.0.0.1:10000 |00d 00:02:06|newcamd| | | 1 | |
+----------------------+------------+-------+--------+----------------+-------+-------------------------------+

musogeek
17-12-2011, 10:49 PM
2011/12/17 21:33:14 9FF48B8 r ATR: 3F FD 13 25 02 50 00 0E 33 B0 0F 69 FE 4A 50 D0 00 00 53 58 02
2011/12/17 21:33:16 9FF48B8 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.57 Mhz
2011/12/17 21:33:17 9FF48B8 r card system not supported
2011/12/17 21:33:17 9FF48B8 r Normal mode failed, reverting to Deprecated Mode
2011/12/17 21:33:20 9FF48B8 r ATR: 3F FD 13 25 02 50 00 0E 33 B0 0E 69 FE 4A 50 D0 00 00 53 58 02
2011/12/17 21:33:21 9FF48B8 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.57 Mhz
2011/12/17 21:33:22 9FF48B8 r card system not supported
2011/12/17 21:33:22 9FF48B8 r card initializing error
2011/12/17 21:33:23 0 s init for all local cards done
This would happen if your frequency is wrong, or there is an issue with the card or reader. I would think the issue is physical, because it should work at the frequency it is initialising on. If your card is ok in the original box then there might be a problem with the reader. You didn't set a frequency in your reader entry in oscam.server. In mine i add;


mhz = 500
cardmhz = 357

but I am not sure if this would make a difference because I think it should still work how it is if there wasn't any other issues.

I had a similar issue with the same resulting log, and it turned out to be a bad card.

master G
17-12-2011, 10:51 PM
Do you see your cards entitlements in oscam web info?

How To See Your Card Entitlements When Using Oscam ([Only registered and activated users can see links])

graham1981
17-12-2011, 10:56 PM
This would happen if your frequency is wrong, or there is an issue with the card or reader. I would think the issue is physical, because it should work at the frequency it is initialising on. If your card is ok in the original box then there might be a problem with the reader. You didn't set a frequency in your reader entry in oscam.server. In mine i add;



but I am not sure if this would make a difference because I think it should still work how it is if there wasn't any other issues.

I had a similar issue with the same resulting log, and it turned out to be a bad card.


Thanks, i have tried that, does it make a difference if the protocol is changed from mouse to newcamd ?

musogeek
17-12-2011, 11:15 PM
Thanks, i have tried that, does it make a difference if the protocol is changed from mouse to newcamd ?
no because you need to use a protocol related to your card reader in oscam and newcamd isn't related to a local reader

graham1981
17-12-2011, 11:22 PM
Hi, no entitlements shown it just says You have to set saveinithistory=1 in your config to see Entitlements!

graham1981
17-12-2011, 11:24 PM
When was the last time this white UK card was used?

It was used today in my sly box, wanted to make sure it worked =)

master G
17-12-2011, 11:30 PM
Fill in the missing config fields with these

Oscam Sly UK Configs For Updating Entitlements ([Only registered and activated users can see links])

musogeek
17-12-2011, 11:41 PM
Your card was working today in the original receiver and you are getting a card initializing error, so I don't think you have an entitlement issue. Your card is not being read properly. Can't see anything in your configs and you have tried what we suggested. You said yourself your reader was years old, maybe it is time to get another one:feel_good:

graham1981
17-12-2011, 11:41 PM
Thanks for all your help. still not working though,

lastest oscam log is

2011/12/17 22:38:19 0 s 37 tier-id's loaded
2011/12/17 22:38:19 0 s 1000 provid's loaded
2011/12/17 22:38:19 0 s can't open file "/usr/local/etc/oscam.ird" (errno=2 No such file or directory) i***** guessing not loaded
2011/12/17 22:38:19 0 s Starting listener 0
2011/12/17 22:38:19 0 s monitor: disabled
2011/12/17 22:38:19 0 s Starting listener 0
2011/12/17 22:38:19 0 s camd35: disabled
2011/12/17 22:38:19 0 s Starting listener 0
2011/12/17 22:38:19 0 s cs378x: disabled
2011/12/17 22:38:19 0 s Starting listener 0
2011/12/17 22:38:19 0 s newcamd: initialized (fd=4, port=10000, crypted)
2011/12/17 22:38:19 0 s -> CAID: 0963 PROVID: 000000
2011/12/17 22:38:19 0 s Starting listener 0
2011/12/17 22:38:19 0 s pandora: disabled
2011/12/17 22:38:19 0 s Starting listener 0
2011/12/17 22:38:19 0 s radegast: disabled
2011/12/17 22:38:19 0 s http thread started
2011/12/17 22:38:19 0 s reader check thread started
2011/12/17 22:38:19 0 s check thread started
2011/12/17 22:38:19 0 s creating thread for device /dev/ttyUSB0
2011/12/17 22:38:19 0 s loadbalancer: can't read from file /tmp/.oscam/stat
2011/12/17 22:38:19 0 s waiting for local card init
2011/12/17 22:38:19 8970FD0 h HTTP Server listening on port 8888
2011/12/17 22:38:21 896F7D8 r reader ***uk initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)
2011/12/17 22:38:22 0 ***uk card detected
2011/12/17 22:38:26 896F7D8 r ATR: 83 40 37
2011/12/17 22:38:26 896F7D8 r ERROR: Could not read reader->convention
2011/12/17 22:38:26 896F7D8 r Error activating card.
2011/12/17 22:38:31 896F7D8 r ATR: 3F FD 13 25 02 50 00 0F 32 B0 0E 69 FF 4A 50 D1 00 00 53 59 02
2011/12/17 22:38:33 896F7D8 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.57 Mhz
2011/12/17 22:38:36 896F7D8 r card system not supported
2011/12/17 22:38:36 896F7D8 r Normal mode failed, reverting to Deprecated Mode
2011/12/17 22:38:40 896F7D8 r ATR: 3F FD 13 25 02 50 00 0E 33 B1 0F 69 FE 4A 50 D0 00 00 53 59 03
2011/12/17 22:38:41 896F7D8 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.57 Mhz
2011/12/17 22:38:42 896F7D8 r card system not supported
2011/12/17 22:38:42 896F7D8 r card initializing error
2011/12/17 22:38:42 0 s init for all local cards done
2011/12/17 22:38:42 0 s anti cascading disabled
2011/12/17 22:38:42 8975848 c client connected to 10000 port
2011/12/17 22:38:42 8975848 c anonymous disconnected from 127.0.0.1
2011/12/17 22:38:42 8975848 c thread B6C9FB70 ended!
2011/12/17 22:38:42 89740E0 c client connected to 10000 port
2011/12/17 22:38:42 89740E0 c anonymous disconnected from 127.0.0.1
2011/12/17 22:38:42 89740E0 c thread B74E8B70 ended!


I have not added the boxkey from original box, as I am under the impression that Oscam can read it from the ccard?

graham1981
17-12-2011, 11:42 PM
The clock frequency on my usb infinity (phoenix mode) is 3.68, is that ok?

graham1981
17-12-2011, 11:44 PM
Entitlements for slyuk

Cardsystem Valid To IRD ID (nagra) Provider
unknown n/a FF FF FF FF
Serial Rom ATR
0000000000000000 3F FD 13 25 02 50 00 0E 33 B1 0F 69 FE 4A 50 D0 00 00 53 59 03
Type Caid Provid ID Class Start Date Expire Date Name

graham1981
17-12-2011, 11:45 PM
Your card was working today in the original receiver and you are getting a card initializing error, so I don't think you have an entitlement issue. Your card is not being read properly. Can't see anything in your configs and you have tried what we suggested. You said yourself your reader was years old, maybe it is time to get another one:feel_good:

Well its funny you say that, i do have a Gem plus twin device, any idea on getting that put to use?

musogeek
17-12-2011, 11:46 PM
no harm in trying the other frequencies

master G
17-12-2011, 11:52 PM
Entitlements for slyuk

Cardsystem Valid To IRD ID (nagra) Provider
unknown n/a FF FF FF FF
Serial Rom ATR
0000000000000000 3F FD 13 25 02 50 00 0E 33 B1 0F 69 FE 4A 50 D0 00 00 53 59 03
Type Caid Provid ID Class Start Date Expire Date Name

There is a problem with your reader setup, you should see like this

[Only registered and activated users can see links] ([Only registered and activated users can see links])

graham1981
17-12-2011, 11:55 PM
ok, how do i get to that? sorry for being a pain =)

graham1981
17-12-2011, 11:59 PM
2011/12/17 22:57:24 82497D8 r reader ***uk initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)
2011/12/17 22:57:25 0 ***uk card detected
2011/12/17 22:57:29 82497D8 r ATR: 3F FD 13 25 02 50 00 0F 33 B0 0F 69 FF 4A 50 D0 00 00 53 59 02
2011/12/17 22:57:31 82497D8 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.57 Mhz
2011/12/17 22:57:34 82497D8 r card system not supported
2011/12/17 22:57:34 82497D8 r Normal mode failed, reverting to Deprecated Mode
2011/12/17 22:57:38 82497D8 r ATR: 3F FD 13 25 02 50 00 0F 33 B0 0F 69 FF 4A 50 D0 00 00 53 59 02
2011/12/17 22:57:39 82497D8 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.57 Mhz
2011/12/17 22:57:45 82497D8 r card system not supported
2011/12/17 22:57:45 82497D8 r card initializing error
2011/12/17 22:57:45 0 s init for all local cards done



Feel so close to getting it working.... but card system not supported?

graham1981
18-12-2011, 12:00 AM
no harm in trying the other frequencies

Tried them, still the same

musogeek
18-12-2011, 12:03 AM
Might sound silly, but I have had that error with my reader in my receiver, and was due to either a bit of dust or the card being out of line or not in properly, try giving it a good blow to rid it of dust and wriggle the card around a bit in the reader! worth a go!

master G
18-12-2011, 12:04 AM
You will see this by following the link in post #15, i think the problem is your usb reader is not installed/configured correctly. Hopefully another member has the same reader & can advise, Check against this Tutorial: How to install Infinity USB programmer on a Debian with CCcam ([Only registered and activated users can see links])

graham1981
18-12-2011, 12:08 AM
You will see this by following the link in post #15, i think the problem is your usb reader is not installed/configured correctly. Hopefully another member has the same reader & can advise, Check against this Tutorial: How to install Infinity USB programmer on a Debian with CCcam ([Only registered and activated users can see links])

Hiya, I have looked at that, but its only for CCCam and not Oscam as the reader, the config files that are there are



SERIAL READER : /dev/ttyS0
SMARTCARD CLOCK FREQUENCY : /dev/ttyS0 3570000
TRY ALL CHIDS : /dev/ttyS0
BOXKEY : /dev/ttyS0 XX XX XX XX
SERVER LISTEN PORT : XXXXX

would any of that be able to be added to Oscam.server or would it go into CCCam.Cfg its just confusing because i was under the impression the reason we use oscam rather than cccam to read the cards is because its more reliable etc.

master G
18-12-2011, 12:14 AM
Hiya, I have looked at that, but its only for CCCam and not Oscam as the reader, the config files that are there are



SERIAL READER : /dev/ttyS0
SMARTCARD CLOCK FREQUENCY : /dev/ttyS0 3570000
TRY ALL CHIDS : /dev/ttyS0
BOXKEY : /dev/ttyS0 XX XX XX XX
SERVER LISTEN PORT : XXXXX

would any of that be able to be added to Oscam.server or would it go into CCCam.Cfg its just confusing because i was under the impression the reason we use oscam rather than cccam to read the cards is because its more reliable etc.

If you have any of the following lines in your cccam.cfg you need to remove them


SERIAL READER : /dev/ttyS0
SMARTCARD CLOCK FREQUENCY : /dev/ttyS0 3570000
TRY ALL CHIDS : /dev/ttyS0
BOXKEY : /dev/ttyS0 XX XX XX XX

graham1981
18-12-2011, 12:16 AM
yeah none of the above in cccam.config

master G
18-12-2011, 12:24 AM
I am sure the problem is either reader setup or faulty reader, i have never used the model you have so am afraid i cannot really help with that bit. Hopefully another member will know, If it is faulty another option would be to use yoour receiver as the reader until you get a replacement.

graham1981
18-12-2011, 12:32 AM
=) We have a little progress!, card is now reading nicely!. I was using a crappy USB to serial adapter, now im not and its working like a charm.

But...... I can see all the entitlements in Oscam, but none in CCcam. Any ideas?

master G
18-12-2011, 12:35 AM
=) We have a little progress!, card is now reading nicely!. I was using a crappy USB to serial adapter, now im not and its working like a charm.

But...... I can see all the entitlements in Oscam, but none in CCcam. Any ideas?

This is how it should be mate, your card is now read by oscam so only oscam will show entitlements.

graham1981
18-12-2011, 12:39 AM
ah great stuff, so i just add my friend as an F line in CCcam.cfg ?

master G
18-12-2011, 12:42 AM
Yes mate just continue using cccam as you are used to for sharing purposes.