sti7111 based unknown clone

  • Hi everyone,


    I have an unknown Chinese satellite receiver with sti7111 CPU, 256 RAM and 64 NOR.

    Can anyone tell if it possible to install spark/enigma on a receiver only with NOR? It seems like the current sti7111 u-boot images (available for download in the forum) are built for reading from nand memory.

    The final aim is to install enigma2/spark if possible.


    Here are some logs (the printenv and help commands are not available :()


    Thanks in advance.

  • What is installed on it now?


    It is hard to tell without more info about the uboot.


    Possibly you could re-partiton the mtd, but it seems there is only 128MB, which would be limiting.


    From my spark7162:

    Code
    1. SPARK7162:~# cat /proc/mtd
    2. dev: size erasesize name
    3. mtd0: 00100000 00020000 "uboot"
    4. mtd1: 00a00000 00020000 "Spark kernel"
    5. mtd2: 00700000 00020000 "Reserve0"
    6. mtd3: 00200000 00020000 "Reserve1"
    7. mtd4: 16c00000 00020000 "Spark Userfs"
    8. mtd5: 00800000 00020000 "E2 kernel"
    9. mtd6: 07700000 00020000 "E2 Userfs"


    Possibly you could boot from USB or NFS, but again depends on uboot.

  • I can't say really what is installed at the moment on it. It seems like some modified (with very little functionality) firmware. For sure it is not spark or enigma.

    At the moment I am trying to boot the kernel from an usb and I achieved a little success:


    Code
    1. Loading Ramdisk to 80da0000, length 0025f98f ... OK
    2. fulanid: Couldn't find stb_id, use default: 03:00:04:00:00:06:b7fulanid: Couldn't find mac address, use default: 00-00-0F-00-96-B7  Unknown Amd/Fujitsu Extended Query version 1.5.physmap-flash physmap-flash: map_probe failedRAMDISK: incomplete write (-28 != 32768) 4194304Root-NFS: No NFS server available, giving up.VFS: Unable to mount root fs via NFS, trying floppy.Kernel panic - not syncingRebooting in 3 seconds..


    And here is the output from the original u-boot and kernel:



    After the "Starting httpd" there is no more output in the console.

  • I use two usb drives - one for the kernel and one for the root dir (with one usb drive and two partitions it didn't work for me).

    But for the moment I couldn't manage to start the root dir.

    I think it is a problem concerning the u-boot and the presence only of NOR memory.

  • For USB/NFS boot the NOR is not used, so it should not matter


    Is there no printenv command, or does it just give an error?


    The uboot may support tftp, have you looked into that?

  • There is no printenv command at all. I did not try to load anything via the network for the moment.

    My aim is to use usb drive so I could use the receiver anywhere. So could you please help me with the commands that should set boot of the kernel and root from a usb drive? More or less I managed to load the kernel (uImage), but still I have problems with the root. Should I have the folders tree ready on the usb drive, or I could provide directly the root image (e2jffs2.img)?

    I will be grateful if you may help me with the required commands.

  • First, here is a link for uboot commands in case you do not have: https://www.denx.de/wiki/U-Bootdoc/BasicCommandSet


    The root needs to be the extracted img, or for many images, they have a USB option which is a tar.gz file containing all the files. The partition on the USB probably needs to be ext2.


    Attached script can be used to extract the files from an e2jffs2.img


    basic manual steps would be to make two partitions on a flash drive - first a small fat partiton for the uImage file and the second a ext2 partition to put the enigma2 files.


    commands would then be something like:


    fatload usb 0:1 80000000 uImage 

    setenv bootargs console=ttyAS0,115200 root=/dev/sda2 rootfstype=ext2 rw coprocessor_mem=4m@0x40000000,4m@0x40400000 printk=1 printk.time=1 nwhwconf=device:eth0,hwaddr:00:80:E1:12:40:69 bigphysarea=6000 stmmaceth=msglvl:0,phyaddr:2,watchdog:5000 panic=10 rootwait usb_storage.delay_use=0 

    bootm 80000000

  • I tried at least 10 different kernel images but always I get the same error:


    It looks like the kernel could not recognize the NOR memory (that was my biggest concern).

    Is it possible to solve this over the u-boot arguments? Or could you suggest a kernel image supporting NOR memory also?

  • It looks like it recognizes it, but maybe the problem is the partition map is different than what it is expecting???


    I found this: https://www.denx.de/wiki/DULG/…figurationOfMTDPartitions

    but checking the kernel for my spark7162, I see it is not enabled.


    Attached is a script you can run to extract the kernel config from an uImage file. (if enabled)


    You may have to build your own kernel. There are 2 main development environments to choose from.

    One is the duckbox developers: https://github.com/Duckbox-Developers/

    The other is from open embedded alliance: https://github.com/oe-alliance

    Taapat has a custom build environment for the spark7111 from oe-alliance: https://github.com/Taapat/vuplus-fulan-openpli-oe-core


    Each has its pluses and minuses...



    These links may also be helpful in setting up a kernel:

    http://processors.wiki.ti.com/…Filesystem_in_NOR_or_NAND

    http://how-to.wikia.com/wiki/H…_Technology_Devices_(MTD)

  • Do you think it is possible to use the current kernel to run the enigma2 root?

    As I have the following partitions:

    Code
    1. dev:    size   erasesize  name
    2. mtd0: 00040000 00020000 "boot"
    3. mtd1: 00020000 00020000 "boot config"
    4. mtd2: 004a0000 00020000 "kernel"
    5. mtd3: 01a00000 00020000 "root"
    6. mtd4: 02100000 00020000 "var"
    7. mtd5: 03fc0000 00020000 "firmware"
    8. mtd6: 04000000 00020000 "nor"

    If I rewrite the root blocks with a e2jffs2.img file, should it run correctly?

    And do you know what is the purpose of the var partition?

    And what should the firmware partition contain: kernel ,var and root, or only root and kernel or something else?

    NOR partition should contain the whole nor memory right? If I messed up something (most probably), I should be able to restore the nor from that image (wisely I backed up all these partitions to bin files :)), right?

  • An interesting thing is that in the var partition there is an oscam file, built for enigma2 (or at least enigma2 is mentioned there).

    Is that mean that I could install some enigma2 apps (plugins). I saw there are a multiboot plugin, an update plugin and etc. Could that help to install enigma2 via the existing plugins?

    Files

    • oscam.rar

      (697.43 kB, downloaded 3 times, last: )
  • It is common to the /var folder to be separated from the rest of the file system because it can contain user files and logs which can grow and fill up the disk - so separating is a way of protecting the root file system.


    Using the current kernel, you would also need the current file system because it contains the modules (drivers) which were built specifically for that kernel.


    oscam has some spesific things for enigma2, but it also works also with Spark and if you do not recognize the current application as enigma2, it probably is Spark.


    It may be possible to add enigma2 to the existing file system, but there may be space issues. You would probably need a combination of the NOR and a USB flash drive.


    You should look at the root file system and look at things like the /etc/inittab and /etc/fstab to see what it mounts and runs after boot.


    If you upload the bin files someplace, I could take a look at them.


    the oscam is:

  • I did not have time to look at the files, but a quick look a the duckbox developers source code showed there are some well known boxes with NOR.

    https://github.com/Duckbox-Dev…cripts/flash_part_w_fw.sh


    I did not look through all the maps, but maybe one matches, or is close to your box?


    You can either build your own image, or you can try a build from one of the groups. For sure HDMU has some builds for these boxes:

    http://www.hdmedia-universe.co…ges.php?pageid=1&tabid=33

  • Hi, Has anyone achieved improvement for this model? I have the same Chinese copy and also want to install enigma2 soft. When press the Power button and switch on it shows SUUP. Than can update the original software which size is 24 MB.

    when starting the receiver has this info:


    Board: STx7111-Mboard (MB618) [32-bit mode]



    U-Boot 1.3.1 (Apr 24 2013 - 15:09:16) - stm23_0045



    DRAM: 256 MiB


    NOR: 64 MiB


    *** Warning - bad CRC, using default environment



    In: serial


    Out: serial


    Err: serial


    INIT: version 2.86 booting




    Board: STx7111-Mboard (MB618) [32-bit mode]



    U-Boot 1.3.1 (Apr 24 2013 - 15:09:16) - stm23_0045



    DRAM: 256 MiB


    NOR: 64 MiB


    *** Warning - bad CRC, using default environment



    In: serial


    Out: serial


    Err: serial


    INIT: version 2.86 booting


    INIT: Entering runlevel: 3


    Network service.


    ifdown: interface eth0 not configured


    ifconfig: SIOCGIFFLAGS: No such device


    Sat Jan 1 00:00:19 CET 2011ftpd.[$ OK ]


    Starting smbd.Starting portmap.* Looking for chipset model and version...


    $Starting NFS services: [$ OK ]


    $Starting NFS quotas: STx7111 C detected (32BITS)


    * Loading companions


    [$ OK ]


    $Starting NFS daemon: [$ OK ]


    $Starting NFS mountd: [$ OK ]


    Starting httpd.* Inserting Multicom


    * Inserting STAPI Module


    execute user script level 3, /var/bin/init.d/3.emu.sh.