Very strange OSCAM failures

  • I run oscam-emu 11392 on OpenBH4.1 and have had a very strange failure twice in the past three days. I was watching a channel using a share that suddenly stopped, other channels on the same share worked fine. Restarted cam - now all shared channels lost. Checked PV channels - all stopped opening! Restart GUI - still nothings opens. Do a complete power-cycle, still nothing open. To get channels back the only solution (that I have found) is to reload the most recent backup image.


    Am I alone withe this issue? Any idea what the problem is? Any idea what the solution might be?


    Thanks.

  • did you check if oscam still running (when channels stoped working?)

    do you have any reader for afn channels?

  • No I did not check that oscam was still running, but I did restart it. Yes I have a reader for AFN - which doesn't need a share, so that is why I tried afn but nothing. For all the world it is as if there is something like a "memory leak" which is not released even with a restart??

  • there is a little bug in afn reader and crashes oscam. delete this reader and retry...

  • The whole point of switching to oscam was for afn, so running without afn reader is pointless - might as well go back to cccam. Also fault only shown up twice in three days means I would need to run for a very long time (without afn) to decide whether the problem had gone. Is this "little bug" fixed in any future releases of oscam-emu (I am currently on 11392)?

  • i think it is less in 11397,but it is still there (i don't know if there is any point for fix).

    oscam isn't only for afn,but also tandberg and powervu,which cccam can't handle...

  • reload a back up,because oscam is crashing?

    when i used afn,i just did a reboot and than a few times restart oscam...(and checking it if it works through oscam webif)